Cellular Antennas Posts

Posted By

LTE cellular communication for the Honeywell LYNX Touch L5210 and L7000 systems is now available! The Honeywell LTE-L57V will provide these systems with ultra fast and reliable cellular service from the Verizon LTE network. The new module is easy to install, and it will ensure that these compatible systems receive cellular connectivity well into the distant future. Overall, we strongly recommend this module for any Honeywell L5210 or L7000.

Alarm Grid has long-touted the benefits of cellular communication. It sends out signals very quickly, and it is the single most reliable way to ensure that a Honeywell security system always remains connected to the AlarmNet server. LTE service represents the forefront in cellular technology, and the Verizon LTE network is one of the finest.

The Honeywell LTE-L57V provides the L5210 and L7000 systems with a way of connecting to the Verizon LTE network so that they can receive active cellular monitoring. This makes the LTE-L57V the prime option for anyone looking to "future-proof" their L5210 or L7000. Unlike the 3G and CDMA cellular networks, the LTE network should be in service well into the distant future, thereby providing a longer lifespan of the cellular alarm system.

In order to use the LTE-L57V, firmware revision 9.00.201 or higher is required. Any newly purchased L5210 or L7000 should already have the latest firmware update out of the box. Thankfully, existing L5210 and L7000 panels can be updated using the LYNXTOUCH-MSD Firmware Updater Tool.

The LTE-L57V is available for purchase now on the Alarm Grid website! Additionally, we will soon be updating our L5210 and L7000 bundled kits to include this module as well. At the present time, we have not heard anything about a possible AT&T LTE module for the LYNX Touch Systems. However, we will be sure to keep you posted and let you know if any information is available.

Update: The AT&T LTE Version is also available! It is called the Honeywell LTE-L57A. The LYNX Touch Panel must be running firmware revision 9.00.209 or higher to support the module.

Another Update: The L5200 can also be updated using the LYNXTOUCH-MSD Firmware Updater Tool. This will allow an L5200 System to use either the LTE-L57A or the LTE-L57V. More information is available here.

Tags: , , , ,

Comments